Checks

SPF exceeds the 10 DNS-lookup limit

Evaluating the SPF record needs more than 10 DNS lookups.

Why it matters

Receivers return a permerror and ignore the policy once the lookup limit is passed.

What to do

Flatten includes or remove unused mechanisms until the lookup count is 10 or fewer.

Reference

SPF records specify which hosts may send mail for the domain.

RFC 7208 — SPF for Authorizing Use of Domains in Email